Página 1 de 1

Como verificar se o equipamento tem suporte para TLS 1.2

MensagemEnviado: Seg Mar 26, 2018 12:18 am
por Admin
A melhor forma de verificar se o equipamento tem suporte para TLS 1.2 é fazer o teste de conexão com o WS GO - NF-e 4.00 utilizando o Certflex - http://www.flexdocs.com.br/DL/uploads/CertFlex.zip


Diagrama de Testes: http://www.flexdocs.com.br/DL/uploads/TLS1.2.pdf

Se o windows do equipamento não tiver suporte para TLS 1.2 vai acontecer o erro:

The requested security protocol is not supported

O suporte para o TLS 1.2 só existe a partir do Windows Vista e Windows Server 2008. https://blogs.msdn.microsoft.com/kaushal/2011/10/02/support-for-ssltls-protocols-on-windows/

Se a versão do windows do equipamento é Windows Vista, 7, 8, 8.1 ou 10 ou Windows Server 2008, 2008, 2008 R2, 2012, 2012 R2 ou 2016 e acontece o erro acima, a provável causa é ausência do .NET 4.5 ou superior.

Recomendamos a instalação do .NET 4.62 https://www.microsoft.com/pt-br/download/details.aspx?id=53344